07-02-2020, 10:40 +0200
AuthorPost
Nemesis08-29-2008, 16:45  
(Guest)
ok er wurde in die liste aufgenommen.

heisst aber jetzt gigatv und das führte zum konflikt mit meinen remindern.
CyBex  09-10-2008, 09:35   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
bin gerade erst ausm urlaub zurueck, ich schau mal drüber.. aber das soll man un zukunft ja dann auch mit aliasen lösen können, dass man einfach "giga" auf "gigatv" verweisen läßt...

EDIT: Wenn du dich doch eh regelmässig meldest, warum machste dir nich einfach nen Account? das tut nich weh :)

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
InTeNsO09-10-2008, 20:09  
(Guest)
TV Script geht nicht, weder Beta noch die Stabile Version. Immer der gleiche Fehler. http://paste.tclhelp.net/?id=11g

Tcl error [tvreply]: extra characters after close-quote


Eggy Version: .... and I am running eggdrop v1.6.18, on Linux 2.6.20.7gen-dirty.
shroud09-10-2008, 20:16  
(Guest)
Zum Kommentar auf der Paste-Seite:

"Und wenn ich das Script in mIRC reinlade, sagt der mir auchn Fehler, bracket missing."

WTF?
InTeNsO09-10-2008, 20:24  
(Guest)
in mIRC kann man checken ob Klammern fehlen oder nicht
ändert aber trotzdem nichts dadran das in der nopaste fehler angezeigt werden
CyBex  09-10-2008, 21:28   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
"fehler" mit den brackets behoben.. wobei es kein wirklicher fehler is.. denn man kann in wirklich es so schreiben: \[info] .. aber ich habe die nu alle in \[info\] geändert...

http://paste.tclhelp.net/?id=11i

das script wird exact so wie es aufm webserver is au ch von meinem bot geladen der jeden tag um restartet wird, da is kein fehler drin, sowas krieg ich mit ;-)

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
InTeNsO09-10-2008, 22:18  
(Guest)
same problem

TCL_ERROR: scripts/tv.tcl:  error: extra characters after close-quote

Muss das Script in irgendeiner bestimmten reihenfolge geladen werden oder sowas?
burn  09-11-2008, 08:07   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Lädst du dieses Script in Mirc ein? Oder nutzt du einen Eggdrop/Windrop?

Weil falls es mittlerweile eine Erweiterung für Mirc gibt, die es ermöglicht, TCL-Scripte zu lesen, dann schätze ich liegt es an dieser Erweiterung.

Weil auf dem Eggdrop läuft das Script problemlos (auch bei mir).
CyBex  09-11-2008, 09:53   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
lädst du evt das script per copy+paste erst in einen windows-editor (der vermutlich dann noch zeilenumbruch macht) rein und sendest es dann zu dem server wo dein eggdrop läuft?

wenn es auf nen linux server läuft, mach einfach mal:
                                                                                                                              
1
2
wget http://cybex.b0rk.de/files/tcl/powered/tv.beta.1.0.7.tcl.txt; # ziehen
mv tv.beta.1.0.7.tcl.txt tv.tcl; # gleich umbenennen nach tv.tcl


mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
InTeNsO09-12-2008, 23:42  
(Guest)
Ziehe die komplette Datei vom Server und uploade die dann so aber der Fehler bleibt trotzdem...
CyBex  09-13-2008, 00:37   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
                                                                                                                              
01
02
03
04
05
06
07
08
09
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
von:/home/NewsFlash/etc/scripts.Test# wget http://cybex.b0rk.de/files/tcl/powered/tv.beta.1.0.7.tcl.txt
--00:35:50--  http://cybex.b0rk.de/files/tcl/powered/tv.beta.1.0.7.tcl.txt
=> `tv.beta.1.0.7.tcl.txt'
Resolving cybex.b0rk.de... 217.160.128.86
Connecting to cybex.b0rk.de|217.160.128.86|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 58,298 (57K) [text/plain]

100%[=========================================================================================================================================================>] 58,298        --.--K/s

00:35:50 (43.89 MB/s) - `tv.beta.1.0.7.tcl.txt' saved [58298/58298]

von:/home/NewsFlash/etc/scripts.Test# mv tv.beta.1.0.7.tcl.txt tv.tcl

00:35:22 <NewS-FlasH> Connected to NewsFlash, running eggdrop v1.6.17
00:35:22 <NewS-FlasH> Hey CyBex!  My name is NewsFlash and I am running eggdrop v1.6.17, on Linux 2.6.18-6-686.
00:35:22 <NewS-FlasH> Local time is now 00:35
00:35:22 <NewS-FlasH> You are an owner of this bot. Only +n users can see this! For more info,
00:35:22 <NewS-FlasH> *** CyBex joined the party line.
00:35:39 <CyBex-> .doit source scripts.Test/tv.tcl
00:35:40 <NewS-FlasH> [00:35] TV Script v1.0.7.2 loaded (scripts.Test/tv.tcl)
00:35:40 <NewS-FlasH> Tcl: load "scripts.Test/tv.tcl v1.0.7.2",8,1
00:35:40 <NewS-FlasH> Tcl: ready
00:35:40 <NewS-FlasH> Tcl: run


mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
take2  09-14-2008, 15:01  
Member since 09/2008
4 Posts
hey ho, also als erstes mal ein lob an den ersteller des scripts, es ist echt super! ich habe nur ein problem, ich habe mir gestern die neuste version vom script (beta) eingerichtet. klappt soweit auch alles bis auf zwei kleinigkeiten. zum einen kommt in abstand von 5 minuten immer diese message die vorher nicht kam:
(02:50:53pm) (mytake2) [15:50] Tcl error in script for 'timer96949':
(02:50:53pm) (mytake2) [15:50] can't read "::tv(sender_kanald)": no such element in array

und zum anderen wenn ich "!tv premierehd" eingebe, spuckt der bot kein resultat aus und dieser fehler wird angezeigt:
(02:51:08pm) (mytake2) [15:50] Tcl error [tvreply]: can't read "::tvcache(premierehd)": no such element in array
wäre cool wenn mir jemand weiterhelfen könnte! danke schon mal im vorraus, gruß take2
nikk09-17-2008, 10:46  
(Guest)
Ich find das Script auch absolut Klasse!
Ich hab allerdings auch das selbe Problem wie mein Vorredner mit den timern.
Sobald das Script ne Weile geladen ist, gibt es auch diese Timer Fehlermeldungen:
can't read "::tv(sender_kanald)": no such element in array
take2  09-18-2008, 11:50  
Member since 09/2008
4 Posts
dazu kommt noch, dass er nicht mehr die tv datenkbank updatet. also wenn ich beispielsweise den bot am mittwoch neugestartet habe und dann donnerstags das tv programm abfrage, kommen die sendungen vom tag zu vor (mittwoch). woran liegt das? ich könnte hilfe gebrauchen ;-)
CyBex  09-18-2008, 16:21   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
hmm.. Also KanalD (268) wurde scheinbar von TV Movie entfernt. Steht aber erstmal in der init-tv-liste drin. Scheinbar muss man den da entfernen..
Also muss der scheinbar aus der Basis Senderliste raus. Allerdings sollte das problem auch mit der "stable" auftretten.
Bei mir steht der Sender scheinbar noch im Cache, aber ob er noch aktualisiert worden is kann ich nich sagen, da die Sendungen codiert sind.

Das updaten erfolgt jeden morgen um 5 Uhr morgens. Da sollte es eigentlich auch keine Probleme geben.. ruf doch einfach mal "cachetvdata" mit tcldebug oder von der partyline mit .tcl auf und gucke ob es da zu einen Fehler kommt..

Den sender PremiereHD gibt es nich, es is glaub ich eh nur Premiere1 in besserer auflösung und ton, also einfach unter premiere1 gucken...

In der Beta is nun "KanalD" entfernt.

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
take2  09-18-2008, 18:10  
Member since 09/2008
4 Posts
okay der fehler mit "kanald" kommt jetzt nicht mehr. beim updaten tritt auch kein fehler auf, mal gucken ob es morgen geht. kann man irgendwo die zeit ändern wann er die tv cache datei updaten soll? evtl liegts daran das ich bei mir um 5 uhr morgens disconnects habe (wobei ich nicht glaube das es daran liegt).
was mich wundert ist, in der tv sender liste ist "premierehd" eingetragen, warum kann man den dann nicht anzeigen lassen? =)

edit: premierehd funzt jetzt auch, warum auch immer. danke!!
CyBex  09-18-2008, 20:47   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
cachezeitpunt is ein einfacher bind.. kannste ja erstmal oben ins script schreiben:

bind time - "MM HH *" cachetvdata

vor 5 uhr machts keinen sinn da tv-movie die seite erst zu diesem zeitpunkt aktualisiert, aber du könntest zB noch mal um 7uhr nochmal cachen:

bind time - "00 07 *" cachetvdata

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
take2  09-19-2008, 10:09  
Member since 09/2008
4 Posts
also das aktualisieren klappt jetzt auch. ich glaube die probleme wurden mit dem kanald alle entfernt, warum auch immer. vielen dank für den guten und schnellen support!
echt ein tolles script..  ;-)
InTeNsO09-29-2008, 21:17  
(Guest)
Egal wie ich es uploade, fehler sind immer die gleichen :(
Dabei ist es ja echt gut das script.
                                                                                                                              
1
2
3
4
5
[21:06] TV Script v1.0.7.3 loaded (scripts/tv.tcl)
[21:06] TCL_ERROR: scripts/tv.tcl: error: extra characters after close-quote
[21:07] Tcl error in script for 'timer13':
[21:07] Tcl error in script for 'timer19':
[21:07] Tcl error in script for 'timer51':

CyBex  09-30-2008, 14:54   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
du bist aber der einzige der dieses problem hat, und das wort "upload" is in dem zusammenhang halt auch komisch.. probier es auf einen anderen weg, zB einen der oben beschriebenen.. ich kann dir nich mehr helfen ausser es immer und wieder selbst zu probieren und da gehts... also musst du wohl was bei dir ändern... viel erfolg..

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Nemesis10-10-2008, 21:52  
(Guest)
(02:50:53pm) (mytake2) [15:50] Tcl error in script for 'timer96949':
(02:50:53pm) (mytake2) [15:50] can't read "::tv(sender_kanald)": no such element in array


das problem hatte ich mit der vorherigen beta version auch

werde die neue mal ausprobieren
Nemesis  10-10-2008, 22:32  
Member since 10/2008
1 Post
  22:28:47   [)Morningwood] [22:29] Getting info for "kanal7int"... (88 / 192)
  22:28:51   [)Morningwood] [22:29] Got info (found 19 entries)
  22:29:05   [)Morningwood] [22:29] Tcl error in script for 'timer52760':
  22:29:05   [)Morningwood] [22:29] can't read "::tv(sender_kanald)": no such element in array
  22:29:59   [)Morningwood] [22:30] Tcl error in script for 'timer52761':
  22:29:59   [)Morningwood] [22:30] can't read "::tv(sender_kanald)": no such element in array


leider immernoch vorhanden mit der neusten version
Ework11-07-2008, 23:31   | nach .-chan sendet der bot weiter in den channel wenn channelflag n nicht gesetzt ist.
(Guest)
Hallo,
ich habe den bot mit .-chan aus einem channel gepartet.
der channel ist nun opless und hat keine channelflags mehr.

nun sieht jeder der dort noch joint das der bot von aussen in den channel die damalaligen tvsendungen suchmuster reinsendet wenn er was findet.

.status sagt
channel ist nicht mehr gelistet.

er war bei mir vorher in der config auf sticky so das man den channel nur parten konnte mit .+inactive #chan

danach hatte ich ihn von der config genommen.

leider muss es irgendwo noch in der configurationsdatei vorhanden sein. wo speichert den das script die ab?

danke für die hilfe

### TV v1.0.6.3
CyBex  11-12-2008, 07:09   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Die Datei heisst "tv-remind.list" und sollte da liegen wo auch deine Eggdrop-Config liegt...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Vision  02-03-2009, 13:57   | Senderliste
Member since 09/2006
35 Posts
Location: Berlin
Ich wünsche mir immer noch eine Funktion (!tvsender) wo alle Namen der Sender gelistet werden, die in der DB sind.
Oft wissen die User gar nicht wie die Sender heissen.

Cu Vision
CyBex  02-03-2009, 14:22   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
vorgemerkt und wird demnächst eingebaut.. will eh mal wieder weg von der beta zu der stable :-)

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Vision  02-03-2009, 15:44  
Member since 09/2006
35 Posts
Location: Berlin
Quote by CyBex:
vorgemerkt und wird demnächst eingebaut.. will eh mal wieder weg von der beta zu der stable :-)

Super, danke !! :)

Cu Vision
Vision  05-02-2009, 21:38  
Member since 09/2006
35 Posts
Location: Berlin
Nach langer Zeit wollte ich mal wieder die Senderliste aktualisieren.
Wenn ich versuche den Sender Fox 465 in der Senderliste hinzuzufügen, dann kommt beim Datenupdate die Fehlermeldung :
Tcl error in script for 'timer8943':
can't read "::tv(sender_fox)": no such element in array
Tcl error in script for 'timer8944':
can't read "::tv(sender_fox)": no such element in array

usw..

Den Sender gibt es unter Digital arenasat.
Dasselbe hatte ich schon mit dem Sender Extremesports.

Cu Vision
Balu  05-19-2009, 17:12  
Member since 05/2009
2 Posts
Moin , also ich habe ein Bug gefunden beim tv.beta.1.0.7.5.tcl

Und zwar Design: horizontal , also wenn ich das im script auf horizontal stelle und im channel !tv eingebe wird es aber vertikal ausgegeben, in den einstellungen !tv get steht aber auch horizontal drinnen. Es wird dann horizontal dargestellt wenn Flood sich einschaltet und es per Notice dargestellt wird, dann ist es also horizontal.

Vorschlag:
Wenn der bot cachen tuht das man das im channel(einstellbar Aktiven oder Privat channel) zu sehen bekommt und nicht in der Partyline vom Bot.Gerade beim 1 mal oder wenn man neu macht das man weis wann er zu ende gecached hat.

Soviel dazu :)

Eddit: Nick Comedy Central geht auch nicht mehr, btw, Nick endet ja um 20:10h dann kommt ja Comedy Central und das wir im nick nicht mehr angezeigt.
This post was edited 1 times, last on 05-21-2009, 20:10 by Balu
Ben-Kanaan  05-25-2009, 03:00  
Member since 05/2009
2 Posts
Moin Ihr :)

Ich hab nen kleines Problem.
Wenn ich zB
!tv 20:15
eingebe, dann kommen nicht alle hauptsender, sondern nur einer aus der liste, also in dem falle immer nur Pro7.

[02:51:02] <user> !tv 20:15
[02:51:02] -bot- 20:15 (pro7) Fringe - Grenzfälle des FBI (Durch die Wand) [Mysteryserie]

Sollte da nicht eigenrlich ein liste von allen hauptsendern kommen, und was sie um 20:15 senden ?


Wäre dankbar für hilfe :)

Ben-Kanaan
burn  05-25-2009, 08:38   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
08:29:46 <@burn> !tv 20:15
08:29:47 <@|BOT|> 20:15 (pro7) Fringe - Grenzfälle des FBI (Durch die Wand) [Mysteryserie]
08:29:49 <@|BOT|> 20:15 (sat1) Manhattan Love Story [Komödie]
08:29:51 <@|BOT|> 20:15 (rtl) Wer wird Millionär? [Quiz]
08:29:53 <@|BOT|> 20:15 (rtl2) Die Kochprofis - Einsatz am Herd [Doku-Soap]
08:29:55 <@|BOT|> 20:15 (vox) CSI: NY (Brennender Asphalt) [Krimiserie]
08:37:27 <@burn> !tvhaupt
08:37:29 <@|BOT|> Die Hauptsender sind zur Zeit: pro7 sat1 rtl rtl2 vox


---

Schau mal bitte, ob du vielleicht die Hauptsender entfernt hast bzw. eine andere Liste an Hauptsendern hast.
Bei mir funktionierts problemlos.
CyBex  05-25-2009, 10:19   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Vision: wieso willste die Senderliste von Hand aktualisieren? Das Programm holt sich doch immer eine aktuelle Senderliste, sofern man es nicht ausgeschaltet hat...
090525 10:14:15 <@CyBex> !tv foxchannel
090525 10:14:20 <+NewS-FlasH> 10:10 (foxchannel) Providence (Ein Hund kommt in den Himmel), 10:55 (foxchannel) Providence (Schwesternliebe), 11:45 (foxchannel) Las Vegas (Der brennende Beduine)

Balu: ich glaube du verwechselst Horizontal und Vertikal.. Und in der Notice isses Falsch.. Horziontal bedeutet nebeneinander, Vertikal ist untereinander. Und wenn man flood anmacht kommts halt trotzdem Vertikal.. Das is nen kleiner Fehler, das stimmt, aber halt genau umgekehrt wie du beschreiben hast..
Und was macht man bei den Leuten, die den Bot killen, das script eintragen und dann den Bot starten? Da is der ja dann garnich mit einem IRC-Server verbunden wenn er anfängt zu cachen. Aber möglich sollte es schon sein, finds halt relativ unnötig, da nu auch Hauptsender als erstes geholt werden und diese in Kurzerzeit zur verfügung stehen sollten.

Ben: Gucken was du für eine Senderliste hast.. Und die kann für jeden Channel anders eingestellt werden.. also wie burn meinte !tvhaupt oder "!tv get/set haupt"

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Ben-Kanaan  05-25-2009, 11:20  
Member since 05/2009
2 Posts
OK, bei mir geht es jetzt auch.
Ich war wahrscheinlich zu ungeduldig, und er hatte noch nicht alles fertig eingelesen.

[10:45:03] <user> !tv 20:15
[10:45:05] -bot- 20:15 (ard) Jetzt reden wir (Europa vor der Wahl) [Diskussion]
[10:45:07] -bot- 20:15 (zdf) Das Beste kommt erst [Familienfilm]
[10:45:10] -bot- 20:15 (rtl) Wer wird Millionär? [Quiz]
[10:45:11] -bot- 20:15 (rtl2) Die Kochprofis - Einsatz am Herd [Doku-Soap]
[10:45:13] -bot- 20:15 (sat1) Manhattan Love Story [Komödie]
[10:45:15] -bot- 20:15 (pro7) Fringe - Grenzfälle des FBI (Durch die Wand) [Mysteryserie]
[10:45:17] -bot- 20:15 (vox) CSI: NY (Brennender Asphalt) [Krimiserie]
[10:45:19] -bot- 20:15 (kabel1) Money Train [Actionkomödie]

[11:18:33] <user> !tvhaupt
[11:18:34] -bot- Die Hauptsender sind zur Zeit: ard zdf rtl rtl2 sat1 pro7 vox kabel1

Danke ;)
Balu  06-25-2009, 15:34  
Member since 05/2009
2 Posts
Jo hatte es verwechselt.

Aber der Fehler ist immer noch in der Version 1.0.7.6 . Horizontal wirt es ausgegeben im channel und wenn er per Notice umschaltet wirt es Vertikal ausgegeben. Wobei eingestellt ist Horizontal.Also da ist nochn Bug.

Dann ist mir noch aufgefallen das rtlii doof ist rtl2 ist doch ok, also manchmal macht er rtlii und manchmal rtl2. (15:10 (rtlii) Yu- Gi- Oh! (Die große Prüfung) [Animeserie])

Dan gibts Probs mit Kabel1 den hat er manchmal und manchmal findet er den nicht.Er steht aber unter den Hauptsendern drinnen.Sender nicht gefunden erscheint dann wenn ich die Haupsender aufrufe.

Manchmal Ja manchmal Nein, komisch irgendwie.
SambaNase07-06-2009, 08:51  
(Guest)
Hiho,
ich wollte kurz vermelden oder viel mehr rückfragen, ob bei jemanden das tv script (vielen Dank an dieser Stelle <3) noch funktioniert? Bei mir hat es vor einigen Tagen einfach von alleine aufgehört auf Trigger zu reagieren (sowohl die Beta als auch die Stable Version).
Bei der Stable bekomm' ich noch das "tvreply2 t:jetzt <sender> f:0 n:3" Feedback in der Partyline, bei der Beta nur "!TV-Hilfe". Im Channel selber wird nichts ausgespuckt. Gecachet scheint er alles zu haben...
burn  07-06-2009, 08:54   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
08:53:28 <@burn> !tv
08:53:29 <@|BOT|> Syntax: !tv [zeit] [sender]
08:53:32 <@burn> !tv 20:15
08:53:33 <@|BOT|> 20:15 (pro7) Fringe - Grenzfälle des FBI (Ohne Worte) [Mysteryserie]
08:53:35 <@|BOT|> 20:15 (sat1) Die Superlehrer [Doku-Soap]
08:53:37 <@|BOT|> 20:15 (rtl) Rach, der Restauranttester (Die "Waldschenke" in Zahna, in Sachsen-Anhalt) [Doku-Soap]
08:53:39 <@|BOT|> 20:15 (rtl2) Big Brother - Das Finale (Finale) [Doku-Soap]
08:53:42 <@|BOT|> 20:15 (vox) CSI: NY (Böses Foul) [Krimiserie]


Also bei mir gehts noch, habe allerdings auch schon eine etwas ältere Version (v1.0.6.1).
SambaNase07-06-2009, 08:59  
(Guest)
Hmm, sehr merkwürdig. Dann muss das Problem wohl wo anders liegen. Beim Script selber scheinen die Befehle ja anzukommen (Antwort in der Partyline), nur irgendwie ist der Output lost-in-space ...

Danke fürs Testen, bUrN.
CyBex  07-06-2009, 09:02   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Balu, ja ich guck mal wegen des "Design", aber is ja nich ganz so wichtig.

Das mit dem RTL2 is leider in sofern doof, das die vorher 2x geholt worden sind. Und ich eigentlich keine Statische Senderliste mehr haben will. Deswegen ist RTL2 nur noch ein alias auf RTLII (wie er von TV-M*vie) genannt wird. Sonst müßt ich halt den jedesmal neu Statisch hinzufügen wenn die Senderliste aktualisiert wird.

SambaNase: ich vermute einfach mal ein rechte problem: "!tv help" spukt was aus? Die letzte Version hat übrigens NewS-FlasH jederzeit geladen. und kann auch jederzeit in #news.de ausprobiert werden.

Gruß

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
SambaNase07-06-2009, 09:12  
(Guest)
@CyBex: Nur in der Partyline, jedoch nicht im Channel selbst...

                                                                                                                              
1
2
3
4
5
6
channel set #channel +udef-flag-tvmovie
channel set #channel udef-int-tv-allow 1
channel set #channel udef-str-tv-chanmodes op
channel set #channel udef-str-tv-userflags +vo-dq
channel set #channel udef-str-tv-flood 10:300
channel set #channel udef-str-tv-haupt {ard zdf rtl sat1 pro7 vox kabel1}


Was mich an der Sache grad wundert, dass der Bot wohl ganz von alleine (habe nichts an den Scripts oder Einstellungen geändert) aufgehört hat zu antworten (btw, andere Scripts funktionieren weiterhin).
SambaNase07-06-2009, 09:23  
(Guest)
Grad kamen noch ein paar Fehler in der Partyline an:
                                                                                                                              
1
2
3
4
5
6
[09:14] Tcl error in script for 'timer213':
[09:14] no such channel record
[09:15] Tcl error in script for 'timer214':
[09:15] no such channel record
[09:15] Tcl error in script for 'timer215':
[09:15] no such channel record

CyBex  07-08-2009, 15:15   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
damit kann man aber relativ wenig anfangen, da weder procname oder sonst was da steht.. kannst du aml wenn der Fehler kommt, ein:
.tcl set ::errorInfo
machen um mehr Details zu bekommen? Oder vielleicht erstmal die tv.cache (und im Zweifelsfall die tv-remind.list (dann sind aber alle erinnerungen weg)) löschen. Evt stehen da noch sender drin die nicht mehr existieren. Aber ohne genauere Fehlerinfo ist es schwer, da er hier auch nich auftritt...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
SambaNase07-08-2009, 16:19  
(Guest)
Hi CyBex :)

Das mit dem Cache und Reminder List löschen hatte ich schon versucht, funktioniert leider nicht. Nachdem man !tv im channel gemacht hat und der Befehl auch ankam (Repley in der Partyline) ergibt .tcl set :::errorInfo:
Tcl: can't read "state(after)": no such element in array
Tcl:     while executing
Tcl: "after cancel $state(after)"

Beste Grüße
Vision  07-11-2009, 16:23  
Member since 09/2006
35 Posts
Location: Berlin
Ich habe auch ein kleines Problem.
Entweder ich bekomme "Sender nicht gefunden" im Egg angezeigt oder es kommt ein Tcl error....

Ich möchte gerne den Kanal "SkyFussballbundesliga" auch als "Bundesliga" aufrufen können. Außerdem ist der Kanal auch noch in einer Kategorie enthalten.

Ich habe folgendes Probiert (Senderliste gekürzt):
                                                                                                                              
01
02
03
04
05
06
07
08
09
10
11
12
13
14
15
16
17
## Kategorie
set global-tv-kategorie {
    sport "skyfussballbundesliga skysport1 skysport2 skysportaustria dsf eurosport"
}

## Alias
set tv-alias {
    "skyfussballbundesliga" "bundesliga"
}

set ::tv(senderliste) {
    skyfussballbundesliga 484
    bundesliga 484
    SkySport1 485
    SkySport2 486
    usw...
}


Wenn ich das so mache dann bekomme ich beim  Aufruf !tv Bundesliga die Fehlermeldung: Tcl error [tvreply]: can't read "::tvcache(bundesliga)": no such element in array

Was mach ich falsch ?

Cu Vision
CyBex  07-21-2009, 07:41   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
SambaNase: Das ist schon fast eine völlig normale Meldung, wenn man beim HTTP Package mit timeout arbeitet.

Vision: Hast du das Autoupdate ausgeschaltet? Weil sonst werden deine Sender die du per Hand einträgst jeden morgen um 5 Uhr gelöscht, wenn die Senderliste aktualisiert wird...

Balu: Mir is eingefallen warums als Notice so nicht geht. Weil es ist eine Channel einstellung und sobald es ins Private geht, gibs halt dieses Channel-Setting nicht mehr. Man könnte nur eine globale Einstellung machen, das es immer nebeneinander ist und nur bei ausnahmen untereinander ist.

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
InTeNsO08-29-2009, 17:22  
(Guest)
tv script geht plötzlich nicht mehr

hab schon eggy neu aufgesetzt aber wenn ich !tv eintippe kommt keine tvliste mehr....
gh0st`09-05-2009, 14:21  
(Guest)
Also bei mir funktioniert es noch einwandfrei..!
CyBex  09-19-2009, 01:48   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
jo, mal cachetvdata per tcl aufrufen. und im zweifelsfall mal auf der partyline gucken ob da fehler sind. hier sind keiner. :-)

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
pontomedon  09-23-2009, 09:40   | Erweiterungsvorschlag
Member since 09/2009
1 Post
Ein Erweiterungsvorschlag:

Hab bei mir mal folgendes eingebaut:

oben im optionen abschnitt:
                                                                                                                              
1
2
# soll tvsearch nur die hauptsender oder alle durchsuchen?
set tv-tvsearch-nurhaupt 0


unten beim tvsearch bind
                                                                                                                              
1
bind pub - "${::tv-trigger}tvsearch" "tvsearch 1"

durch
                                                                                                                              
1
bind pub - "${::tv-trigger}tvsearch" "tvsearch ${::tv-tvsearch-nurhaupt}"

ersetzt

Weil ich wollte dass auch auf ORF gesucht wird.

Optimal wäre natürlich wenn tvsearch in den aktuellen hauptsendern vom script suchen würde, hab mir tv-m*vie allerdings nicht so genau angeschaut, keine Ahnung ob das geht.

mfg pontomedon
CyBex  09-23-2009, 11:01   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
mein gegenvorschlag wäre ein 2. bind wo man alle sucht, wie "allsearch" oder so.. wo man einfach dann 0 hat...

bind pub - "${::tv-trigger}allsearch" "tvsearch 0"

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Hazard11-21-2009, 10:59  
(Guest)
Seit der neuen version (v1.0.7.6) wird bei mir RTL2 anders angezeigt, also steht jetzt "rtlii" dran, siehe:

|11:38:42| <@BoT> 10:50 (rtlii) Hoffnungslos verliebt [Teenagerkomödie]

wie/wo kann ich das ändern ? also das wieder "RTL2" dran steht.
Advanced options for this topic:

Ignore this topic (Do not list this topic in the "unread topics" search. You are currently not ignoring this topic.)
Hide this topic (Hidden topics are not displayed in the topics list. This topic is currently not hidden.)
Go to forum

Unclassified NewsBoard 1.5.3-d | © 2003-4 by Yves Goergen | Time: 236.4 msec, CPU time: 117 msec, 117 Database queries in 135.3 msec | 16.1 kB (124.6 kB) | Timezone: +0200