01-20-2018, 04:11 +0100
AuthorPost
Vision  06-24-2012, 19:43  
Member since 09/2006
35 Posts
Location: Berlin
Ich hatte das vor ein paar Tagen auch und habe jetzt die 2. Uhrzeit auf 13 Uhr gelegt.

Cu Vision
gh0st07-03-2012, 02:59  
(Guest)
es scheint so als würde das script nicht mehr funktionieren... :( hat tv**ie wieder was verändert?
CyBex  07-04-2012, 09:17   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
ja, bei tvm*vie sind nun 6 spalten statt 4, die haben also wieder ihr komplettes design umgekrempelt...

wir haben zum probieren schon eine alternative, aber halt ohne paytv und es läuft noch nicht alles fehlerfrei..  man könnte auch sagen noch beta status....

http://thommey.tclhelp.net/dl/dl?id=10

nennt sich tv_addon_otr.tcl und sollte nach dem tvscript geladen werden.. dann werden die daten von onlinetvrec*rder geholt.. wir sind auch noch daran interessiert andere addons anzubieten aber momentan haben wir nur dies...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
grml  07-04-2012, 21:54  
Member since 11/2011
18 Posts
Hab das addon mal geladen, aber bekomm einen error
                                                                                                                              
1
2
3
4
[20:52] Starting to cache TV data...
[20:52] Getting TV Stations
[20:52] Tcl error in script for 'timer108956':
[20:52] bad index "0+1": must be integer or end?-integer?

gh0st07-04-2012, 23:55  
(Guest)
Quote by grml:
Hab das addon mal geladen, aber bekomm einen error
                                                                                                                              
1
2
3
4
[20:52] Starting to cache TV data...
[20:52] Getting TV Stations
[20:52] Tcl error in script for 'timer108956':
[20:52] bad index "0+1": must be integer or end?-integer?


das gleiche problem habe ich auch...

Tcl version: 8.4.19 (header version 8.4.19)
CyBex  07-05-2012, 07:37   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Fehler bekannt und wird heute vermutlich geändert.. bei TCL 8.5 tritt der Fehler übrigens nicht mehr auf...

EDIT: Ok, probierts jetzt noch einmal...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
This post was edited 1 times, last on 07-05-2012, 07:47 by CyBex
wirehack707-05-2012, 08:03  
(Guest)
Ist es wieder broken?

Bekomme nur die Meldungen bei einem !tv reload:

[07:01:21] Getting info for stations group 0 (1 / 65)
[07:01:36] Getting info for stations group 6 (2 / 65)

usw. Hat TV M*vie das Markup wieder geändert?
This post was edited 1 times, last on 07-06-2012, 07:35 by CyBex
poseidon  07-05-2012, 09:51  
Member since 09/2011
11 Posts
Mit dem Addon funktionierts ja schon wieder recht nice. Eine kleine Bitte hätte ich allerdings: Bitte auch die österreichischen Sender inkludieren, sind nur neun sender mehr.. dann müsste ich das addon nicht bei jedem update selber patchen..

Der Vollständigkeit halber ist der patch attached.
  The user has attached a file: tv_addon_otr_AT.patch (Save, 1,248 Bytes, downloaded 76 times)
burn  07-05-2012, 09:57   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by wirehack7:
Ist es wieder broken?

Bekomme nur die Meldungen bei einem !tv reload:

[07:01:21] Getting info for stations group 0 (1 / 65)
[07:01:36] Getting info for stations group 6 (2 / 65)

usw. Hat TV M*vie das Markup wieder geändert?

Leider wurden an dieser Seite wieder Anpassungen/Änderungen vorgenommen, so dass unser Skript nicht mehr funktioniert.
Im 1. Post gibt es nun ein OTR Addon, was dir zumindest die meisten Sender bietet, allerdings keine Pay TV Sender, falls du darauf (erstmal) verzichten kannst.
Auf die andere (gewohnte) Seite wird unser Skript demnächst auch wieder angepasst, so dass vermutlich bald wieder alles laufen sollte wie gewohnt.

Das Addon musst du nach dem Laden deines TV Skriptes einbinden, es überschreibt nämlich dann den Part, des Auslesens der Daten.

Quote by poseidon:
Mit dem Addon funktionierts ja schon wieder recht nice. Eine kleine Bitte hätte ich allerdings: Bitte auch die österreichischen Sender inkludieren, sind nur neun sender mehr.. dann müsste ich das addon nicht bei jedem update selber patchen..

Der Vollständigkeit halber ist der patch attached.

Ist geändert, Danke für diesen Verbesserungsvorschlag.
This post was edited 3 times, last on 07-06-2012, 07:35 by CyBex
poseidon  07-05-2012, 10:10  
Member since 09/2011
11 Posts
Danke!

Ich betreibe seit längerem einen grabber für tel*DOTat, und hoste ein php script dass die daten im XMLTV standard zur verfügung stellen kann. Dem script die möglichkeit geben, ein otr-artiges csv zu liefern wäre keine besonders große Änderung, und ein addon dafür wäre trivial (maximal ein paar spalten-indices vom otr addon wären zu ändern). schaut euch die senderliste von tel*DOTat mal an, und sagt mir ob interesse besteht, dann meld ich mich mal im irc.

edit: da wären dann auch die meisten pay-tv-sender dabei. interessant wäre möglicherweise auch das script so zu ändern, dass mehr als eine quelle abgefragt werden kann - man müsste sich nur was überlegen wie man die sendernamen vereinheitlicht.
burn  07-05-2012, 11:03   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by poseidon:
Danke!

Ich betreibe seit längerem einen grabber für tel*DOTat, und hoste ein php script dass die daten im XMLTV standard zur verfügung stellen kann. Dem script die möglichkeit geben, ein otr-artiges csv zu liefern wäre keine besonders große Änderung, und ein addon dafür wäre trivial (maximal ein paar spalten-indices vom otr addon wären zu ändern). schaut euch die senderliste von tel*DOTat mal an, und sagt mir ob interesse besteht, dann meld ich mich mal im irc.

edit: da wären dann auch die meisten pay-tv-sender dabei. interessant wäre möglicherweise auch das script so zu ändern, dass mehr als eine quelle abgefragt werden kann - man müsste sich nur was überlegen wie man die sendernamen vereinheitlicht.

Diese Idee beschäftigt uns schon länger, allerdings wären es halt schon größere Änderungen, weil es doch mehrere Teile mit sich zieht.
Deine Seite bietet sicherlich Pay TV mit an, aber das bietet der vorherige Source ja ebenfalls. Man müsste mal vergleichen, ob dann auch alle deutschen Sender mit dabei sind und natürlich gucken, wie konstant diese Daten sind. Vom Eingangsformat her können wir natürlich an sich alles verarbeiten, es bedarf dann immer nur der jeweiligen Änderung, aber das stellt normal kein Problem da.
grml  07-11-2012, 20:43  
Member since 11/2011
18 Posts
SF2 scheint das script nicht zu kennen?

"Sender nicht gefunden."
poseidon  07-11-2012, 20:53  
Member since 09/2011
11 Posts
Quote by grml:
SF2 scheint das script nicht zu kennen?

"Sender nicht gefunden."

Du müsstest "ch" zur länderliste hinzufügen, analog zu meinem patch für österreich ein paar posts weiter oben, die zeile müsste dann lauten

                                                                                                                              
1
if {[string equal $F "COUNTRY"] && ( [string equal $E "de"] || [string equal $E "at"] || [string equal $E "ch"] ) } {


@burn: vielleicht die 3 sender auch gleich noch rein. oder gleich nach der sprache filtern statt nach dem land? (komischerweise sind at+de+ch = 61 sender, lang=de sind 59 sender.. hab nicht genauer gesucht welche sprache die fehlenden beiden haben..)
burn  07-11-2012, 21:21   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by grml:
SF2 scheint das script nicht zu kennen?

"Sender nicht gefunden."

Dieser Sender ist nun auch mit aufgenommen. Einfach das Addon nochmal runterladen und in deinen Bot einbinden sowie natürlich rehashen.
grml  07-11-2012, 21:29  
Member since 11/2011
18 Posts
Vielen Dank, funktioniert!


Gibt es eigentlich auch eine Funktion das um 20:15 Uhr automatisch bestimmte Sender wie Pro7, RTL.. angezeigt werden?
(am besten auch 5 min. davor)
nitro  07-15-2012, 19:47  
Member since 12/2011
10 Posts
Also ich habe das neue addon drin aber mein bot sagt mir immer noch "Sender nicht gefunden." hat einer ne idee woran es liegen könnte?
ich habe die beta nochmal neu gezogen auch das brachte nix und das addon läd der bot zuletzt.

Connection reset by myself
grml  07-15-2012, 21:08  
Member since 11/2011
18 Posts
hast du vllt. noch die "alten" sendernamen drin, also Pro7HD, RTLHD usw.?

Weil bei der neuen source sind es wieder die normalen sendernamen, also ohne HD
nitro  07-16-2012, 18:41  
Member since 12/2011
10 Posts
nein kein HD drin Und ich hatte Ja Die Beta extra nochmal gezogen auch das brachte nix....

Update:
danke für die hilfe aber in chanset lag das problem dort hatte er noch die HD sender drin :D

Connection reset by myself
This post was edited 1 times, last on 07-16-2012, 19:46 by nitro
Vision  07-27-2012, 22:37  
Member since 09/2006
35 Posts
Location: Berlin
Ich bekomme gerade die Fehlermeldung:

Tcl error [chktimetv]: unable to convert date-time string "26:53"

und jetzt

Tcl error [chktimetv]: unable to convert date-time string "40:30"

Die Fehlermeldung wiederholt sich alle 5 Minuten.

Cu Vision
This post was edited 1 times, last on 07-28-2012, 13:09 by Vision
grml  07-31-2012, 10:51  
Member since 11/2011
18 Posts
Hab gerade auch ein Zeitproblem (aber ohne error im bot).

Wenn ich !tv eingeb, bringt er mir die Sendungen die heute Nacht laufen.
                                                                                                                              
01
02
03
04
05
06
07
08
09
10
11
12
13
|09:45:53| <!grml> !tv
|09:45:55| <%Bot> 00:25 (pro7) Mein cooler Onkel Charlie [Comedyserie]
|09:45:57| <%Bot> 00:20 (sat1) Auf Brautschau im Ausland [Soap]
|09:46:00| <%Bot> 00:00 (rtl) RTL Nachtjournal [MAGAZINE]
|09:46:01| <%Bot> 00:05 (rtl2) Ungeklaerte Morde Dem Taeter auf der Spur [Doku]
|09:46:03| <%Bot> 01:20 (vox) Nachrichten [Nachrichten]
|09:46:05| <%Bot> 00:35 (kabel1) Empire Der Kampf um das Imperium [Historiendrama]
|09:46:08| <%Bot> 01:15 (sf2) Two and a Half Men Mein cooler Onkel Charlie [Comedyserie]
|09:46:09| <%Bot> 00:10 (n24) Ausgemustert Das Ende eines Phantom Jets [Dokumentation]
|09:46:12| <%Bot> 00:10 (dmax) DMAX Der Tag [Dokumentation]
|09:46:14| <%Bot> 00:00 (ntv) Nachrichten [Nachrichten]
|09:46:16| <%Bot> 00:45 (arte) Yourope [Magazin]
|09:46:18| <%Bot> 00:55 (phoenix) Hitlers Manager [Dokumentarreihe]

Die Uhrzeit im Bot stimmt aber.                                                                                                                               
1
2
|09:49:47| <!grml> !time
|09:49:53| <%Bot> Es ist 09:49:51.


Hab es auch schon mit tv reload versucht, aber ist immernoch so.
nitro  07-31-2012, 19:27  
Member since 12/2011
10 Posts
ich habe das selbe problem wie grml das der bot die zeiten von heut nacht zeigt.
auch ein !tv reaload brachte nix wie bei grml.

Connection reset by myself
burn  07-31-2012, 20:07   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Zur Zeit liefert unsere Quelle nur die Daten ab dem 01.08.2012, mal im Auge behalten, ob es ein nur temporäres Problem ist oder ob wir uns ggf. nach eine Alternative umsehen müssen.


EDIT 20:49 Uhr:

Problem sollte nun behoben sein, ihr müsst allerdings nochmal das Addon runterladen, hier hatte sich ein kleiner Fehler eingeschlichen.
This post was edited 1 times, last on 07-31-2012, 21:49 by burn
grml  08-01-2012, 21:15  
Member since 11/2011
18 Posts
Heute stimmen die Daten wieder!
nitro  08-03-2012, 19:30  
Member since 12/2011
10 Posts
Danke Burn

Mit dem Addon Update klappt nun wieder alles bestens.

Eine frage wo muss ich ansetzen das der bot mir die zeit von bis anzeigt?
bsp: 15:00 bis 16:00 (sat1) Familien Faelle

Connection reset by myself
poseidon  08-20-2012, 12:36  
Member since 09/2011
11 Posts
Hat noch jemand das Problem, dass der bot jeden Tag um Mitternacht massenhaft reminder ausspuckt? (die "in 5 minuten" reminder um 23:55 und die "jetzt" reminder um 00:00)

Sieht fast so aus als würde er alle reminder posten, die irgendwann am kommenden tag matchen, weil es scheinen nicht wirklich alle aber die meisten zu sein.

verwende das OTR addon.

mfg poseidon
gh0st09-05-2012, 03:25  
(Guest)
wird eigentlich an einer neuen version gearbeitet, sodass die pay-tv (sky) sender bald wieder zur verfügung stehen?
meh09-09-2012, 01:37  
(Guest)
Quote by poseidon on 08-20-2012, 12:36:
Hat noch jemand das Problem, dass der bot jeden Tag um Mitternacht massenhaft reminder ausspuckt? (die "in 5 minuten" reminder um 23:55 und die "jetzt" reminder um 00:00)

Sieht fast so aus als würde er alle reminder posten, die irgendwann am kommenden tag matchen, weil es scheinen nicht wirklich alle aber die meisten zu sein.

verwende das OTR addon.

mfg poseidon

Genau dieses Problem habe ich auch. Hoffentlich wird das bald gefixt.
nitro  09-14-2012, 12:38  
Member since 12/2011
10 Posts
Quote by meh on 09-09-2012, 01:37:
Quote by poseidon on 08-20-2012, 12:36:
Hat noch jemand das Problem, dass der bot jeden Tag um Mitternacht massenhaft reminder ausspuckt? (die "in 5 minuten" reminder um 23:55 und die "jetzt" reminder um 00:00)

Sieht fast so aus als würde er alle reminder posten, die irgendwann am kommenden tag matchen, weil es scheinen nicht wirklich alle aber die meisten zu sein.

verwende das OTR addon.

mfg poseidon

Genau dieses Problem habe ich auch. Hoffentlich wird das bald gefixt.

Ich schließe mich an... bei ist ist es auch.

Connection reset by myself
gh0st09-15-2012, 02:39  
(Guest)
Quote by nitro:
Quote by meh on 09-09-2012, 01:37:
Quote by poseidon on 08-20-2012, 12:36:
Hat noch jemand das Problem, dass der bot jeden Tag um Mitternacht massenhaft reminder ausspuckt? (die "in 5 minuten" reminder um 23:55 und die "jetzt" reminder um 00:00)

Sieht fast so aus als würde er alle reminder posten, die irgendwann am kommenden tag matchen, weil es scheinen nicht wirklich alle aber die meisten zu sein.

verwende das OTR addon.

mfg poseidon

Genau dieses Problem habe ich auch. Hoffentlich wird das bald gefixt.

Ich schließe mich an... bei ist ist es auch.

benutze auch das otr addon, aber das problem besteht bei mir nicht. aller dings postet er bei mir manchmal die reminder für den nächsten tag..
poseidon  09-15-2012, 08:20  
Member since 09/2011
11 Posts
Quote by gh0st:
benutze auch das otr addon, aber das problem besteht bei mir nicht. aller dings postet er bei mir manchmal die reminder für den nächsten tag..

hm also hast du doch das gleiche problem?
gh0st09-16-2012, 11:42  
(Guest)
Quote by poseidon on 09-15-2012, 08:20:
Quote by gh0st:
benutze auch das otr addon, aber das problem besteht bei mir nicht. aller dings postet er bei mir manchmal die reminder für den nächsten tag..

hm also hast du doch das gleiche problem?

nur das er bei mir nicht alles um mitternacht postet, sondern zb. um 18 uhr postet er ein reminder, die sendung aber erst morgen läuft usw.
Botbenutzer09-25-2012, 09:52   | Fehlermeldung beim neuem Script
(Guest)
hoi bekomme beim neuem script:

08:48:25| |(Spamm0r| [08:48] Starting to cache TV data...
|08:48:25| |(Spamm0r| [08:48] Getting TV Stations
|08:48:25| |(Spamm0r| [08:48] Found 184 Stations
|08:48:26| |(Spamm0r| [08:48] Tcl error in script for 'timer5':
|08:48:26| |(Spamm0r| [08:48] couldn't open "/tmp/tv.cache": no such file or directory

der tmp ordner ist da...

hab ich da noch nen fehler drin? ^^

btw is nen Windrop ;)

My name is Spamm0r and I am running eggdrop v1.6.18, on CYGWIN_NT-5.2 1.5.24(0.156/4/2).

MFG

Botbenutzer
wirehack710-28-2012, 10:49  
(Guest)
Ich habe seit dem letzten Update auf die letzte Beta dieses Problem:

�<�wirehack7�>��� !tv 20:15
�<�opsys�>�� �01:05� (pro7) �Der Fluch der goldenen Blume� [Action]
<�opsys�>�� �23:15� (sat1) �Criminal Minds� [Krimiserie]
�<�opsys�>�� �23:10� (rtl) �Jung kreativ selbststaendig Ich bin mein eigener Boss�
<�opsys�>�� �23:35� (rtl2) �Das Nachrichtenjournal� [Nachrichten]
<�opsys�>�� �23:30� (vox) �Mein Promi Restaurant�
�<�opsys�>�� �23:00� (kabel1) �Abenteuer Leben� [Wissensmagazin]

Irgendwas stimmt nun mit der Zeit nicht. Hat sich da wieder was geändert?
burn  10-28-2012, 20:06   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Irgendwie scheint unsere Datenquelle Probleme mit der Zeitumstellung zu haben.
Dadurch hat sich dort einiges verschoben.
Jetzt ist nur die Frage, beheben die dieses Problem oder müssen wir ein Workaround schaffen?
wirehack710-29-2012, 13:14  
(Guest)
Problem behoben. Lag wohl an TV Movie :)
Sade  10-30-2012, 21:48  
Member since 10/2012
2 Posts
Bei mir besteht das Problem leider weiterhin. Gerade eben nochmal die aktuelle beta und stable getestet, aber weiterhin "Sender nicht gefunden.".

Es kommt auch keine errormeldung auf der Partyline oder ähnliches..

Ich habe sogar diese ausgabe bekommen:

"Starting to cache TV data...
Getting TV Stations
Found 184 Stations"

Aber weiterhin "Sender nicht gefunden."

Hat noch jemand nen Tip?!

Gruß
burn  10-30-2012, 23:09   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by Sade:
Bei mir besteht das Problem leider weiterhin. Gerade eben nochmal die aktuelle beta und stable getestet, aber weiterhin "Sender nicht gefunden.".

Es kommt auch keine errormeldung auf der Partyline oder ähnliches..

Ich habe sogar diese ausgabe bekommen:

"Starting to cache TV data...
Getting TV Stations
Found 184 Stations"

Aber weiterhin "Sender nicht gefunden."

Hat noch jemand nen Tip?!

Gruß
Hallo Sade,

leider geht das normale Stable Script alleine zur Zeit (noch) nicht.
Du benötigst das normale Stable Script sowie das OTR Addon, siehe beide Links im ersten Post.
Sade  11-03-2012, 12:45  
Member since 10/2012
2 Posts
Hallo Sade,

leider geht das normale Stable Script alleine zur Zeit (noch) nicht.
Du benötigst das normale Stable Script sowie das OTR Addon, siehe beide Links im ersten Post.

Vielen Dank für die info burn.
Es funzt wieder alles :D
grml  02-10-2013, 11:00  
Member since 11/2011
18 Posts
Ich hab gerade das problem das die uhrzeit nicht stimmt:

|10:57:47| <%N-Bot> 11:05 (pro7) Die Grosse TV Total Prunksitzung
|10:57:50| <%N-Bot> 11:45 (sat1) Sechserpack [Comedy]
|10:57:51| <%N-Bot> 11:55 (rtl) Once Upon A Time Es war einmal ... [Fantasyserie]

in wirklichkeit kommen die sendungen aber alle genau eine stunde früher, also so müsste es aussehen:

|10:57:47| <%N-Bot> 10:05 (pro7) Die Grosse TV Total Prunksitzung
|10:57:50| <%N-Bot> 10:45 (sat1) Sechserpack [Comedy]
|10:57:51| <%N-Bot> 10:55 (rtl) Once Upon A Time Es war einmal ... [Fantasyserie]
gh0st02-13-2013, 03:33  
(Guest)
Quote by grml on 02-10-2013, 11:00:
Ich hab gerade das problem das die uhrzeit nicht stimmt:

|10:57:47| <%N-Bot> 11:05 (pro7) Die Grosse TV Total Prunksitzung
|10:57:50| <%N-Bot> 11:45 (sat1) Sechserpack [Comedy]
|10:57:51| <%N-Bot> 11:55 (rtl) Once Upon A Time Es war einmal ... [Fantasyserie]

in wirklichkeit kommen die sendungen aber alle genau eine stunde früher, also so müsste es aussehen:

|10:57:47| <%N-Bot> 10:05 (pro7) Die Grosse TV Total Prunksitzung
|10:57:50| <%N-Bot> 10:45 (sat1) Sechserpack [Comedy]
|10:57:51| <%N-Bot> 10:55 (rtl) Once Upon A Time Es war einmal ... [Fantasyserie]

vielleicht liegts auch nur an deinem Server. Es könnte sein das dort die Uhrzeit falsch eingestellt ist.
cRack  02-14-2013, 01:58   | tdom problem
Member since 02/2013
1 Post
zunächst möchte ich mich entschuldigen das ich diesen alten threat herauskrame... vor allem da ich neu bin.

ich habe die alten versionen ohne tdom immer genutzt doch seit der neuerung habe ich das problem, dass ich das package per apt-get installiere es dennoch nicht erkannt wird.

sprich beim restarten des bots wird in der log folgendes angezeigt:
-
Das Tcl Packet 'tdom' wird benoetigt. Download: https://github.com/tdom/ Debian: apt-get install tdom
-

doch tdom ist offensichtlich installiert:
-
apt-get install tdom
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
tdom ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 85 nicht aktualisiert.
-

auf besagtem server nutze ich debian-stable 6 64bit...

kann mir jemand sagen wo mein problem liegt?
Advanced options for this topic:

Ignore this topic (Do not list this topic in the "unread topics" search. You are currently not ignoring this topic.)
Hide this topic (Hidden topics are not displayed in the topics list. This topic is currently not hidden.)
Go to forum

Unclassified NewsBoard 1.5.3-d | © 2003-4 by Yves Goergen | Time: 415.1 msec, CPU time: 208 msec, 106 Database queries in 202.6 msec | 11.7 kB (88.1 kB) | Timezone: +0100