05-30-2020, 06:24 +0200
AuthorPost
CyBex  11-28-2011, 09:43   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
bUrN hat eine neue version zum testen freigebgen, könnt ja mal aktualisieren...

im moment ist aber nur die beta version aktualisiert...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
gh0st`11-28-2011, 20:50  
(Guest)
vielen dank!
grml  11-29-2011, 17:42  
Member since 11/2011
18 Posts
danke auch, geht wieder!

aber mal ne andere frage:

kann es sein das früher bei serien auch der titel der folge dabei stand?
aktuell sieht es ja so aus
"18:10 (pro7) Die Simpsons [Einzelfolge]"
früher:
"18:10 (pro7) Die Simpsons - Ballverlust"

kann auch sein ich täusch mich bzw. wünschte mir es wäre so :P
burn  11-30-2011, 06:51   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Dies kann ggf. vielleicht mal so gewesen sein, allerdings bietet die Seite, von der wir die Daten auslesen, diese Informationen direkt nicht an.

18:10
 Die Simpsons
 
Einzelfolge


So sieht es auf der Seite aus und nur diese Daten lassen sich direkt auslesen.
gh0st`12-04-2011, 15:42  
(Guest)
irgendwas stimmt bei mir nicht.. das tv script cached zwar jeden tag die daten, aber wenn ich im channel die daten abrufe, dann bekomme ich immer den bestand von gestern angezeigt. woran liegt das? hat jemand das gleiche problem?
grml  12-04-2011, 18:09  
Member since 11/2011
18 Posts
Ich hab jetzt das gleiche Problem wie "gh0st"
Shiro12-05-2011, 13:18  
(Guest)
Ja das Problem habe ich auch
ich mache es immer per hand
bind pub n !tvcache cachetvdata
burn  12-05-2011, 13:24   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Ich hatte das Problem auch am Sonntag.
Vermutlich gibt es teilweise Verzögerungen, wann die Seite aktualisiert wird, also die Daten vom neuen Tag erscheinen.
Somit müsste man ggf. nochmal das Cachen von Hand starten, anders lässt es sich erstmal nicht lösen.

Wird sich aber ggf. demnächst vielleicht auch ändern, dass häufiger gecached wird, bzw. vielleicht auch die Daten nochmal abgeglichen werden, ob sie gleich geblieben sind.
poseidon  12-05-2011, 13:38  
Member since 09/2011
11 Posts
moeglicherweise hilfts auch den cachezeitpunkt nach hinten zu schieben, zb auf 6 oder so..
nitro  12-08-2011, 20:40  
Member since 12/2011
10 Posts
Komisch das bei mir noch nicht mal angezeigt wird dass das cache ausgeführt wird.

erst per hand wird es angezeigt
bind pub n !tvcache cachetvdata

 Starting to cache TV data...
 Getting TV Stations
 Found 221 Stations
 Okay, cached all data

dann hab ich den timer auf 6 uhr verlegt auch das brachte nix

Connection reset by myself
burn  12-08-2011, 20:44   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by nitro:
Komisch das bei mir noch nicht mal angezeigt wird dass das cache ausgeführt wird.

erst per hand wird es angezeigt
bind pub n !tvcache cachetvdata

 Starting to cache TV data...
 Getting TV Stations
 Found 221 Stations
 Okay, cached all data

dann hab ich den timer auf 6 uhr verlegt auch das brachte nix

Hast du mal geguckt, ob du noch eine tv.cache in deinem Eggdrop Ordner hast? Weil wenn ja, lädt dein Eggdrop ggf. diese Datei, falls diese noch nicht zu alt sein sollte, anstatt zu cachen.
CyBex  12-08-2011, 21:17   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
die beta version hat jetzt übrigens noch einen 2. cachezeitpunkt um gegen 7uhr und es gibt den befehl !tv reload um cachetvdata per hand anzuwerfen..

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
nitro  12-08-2011, 21:59  
Member since 12/2011
10 Posts
Quote by burn:
Quote by nitro:
Komisch das bei mir noch nicht mal angezeigt wird dass das cache ausgeführt wird.

erst per hand wird es angezeigt
bind pub n !tvcache cachetvdata

 Starting to cache TV data...
 Getting TV Stations
 Found 221 Stations
 Okay, cached all data

dann hab ich den timer auf 6 uhr verlegt auch das brachte nix

Hast du mal geguckt, ob du noch eine tv.cache in deinem Eggdrop Ordner hast? Weil wenn ja, lädt dein Eggdrop ggf. diese Datei, falls diese noch nicht zu alt sein sollte, anstatt zu cachen.

Ja die hat der doch immer in den ordner nach dem cachen
wenn es darin liegt *kopfkratz*
timer auf 5:59 uhr datei löschen - timer auf 06:00 cachen
fleicht is ja das mal so die lösung

Connection reset by myself
Vision  12-12-2011, 16:01  
Member since 09/2006
35 Posts
Location: Berlin
Auch bei mir waren die Daten nun von gestern ;)

Die aktuelle Beta läuft bei mir nicht mehr..
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
usw...

Ich weiß auch gar nicht mehr, was nun gerade die aktuelle Beta ist. Version steht immer noch bei v1.0.8.2. Schöne wäre eine Timeline wie bei Trac , damit man mitverfolgen kann, was geändert wurde.

Cu Vision
nitro  12-12-2011, 18:31  
Member since 12/2011
10 Posts
Quote by Vision:
Auch bei mir waren die Daten nun von gestern ;)

Die aktuelle Beta läuft bei mir nicht mehr..
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
usw...

Ich weiß auch gar nicht mehr, was nun gerade die aktuelle Beta ist. Version steht immer noch bei v1.0.8.2. Schöne wäre eine Timeline wie bei Trac , damit man mitverfolgen kann, was geändert wurde.

also bei mir klappt nun die neue beta


Starting to cache TV data...
Getting TV Stations
Found 221 Stations
Okay, cached all data

ich habe bei mir noch zusätzlich oben im script

bind time - "00 06 * * *" cachetvdata

und er startet nun auch um 6 uhr ;)

Connection reset by myself
burn  12-13-2011, 07:49   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by Vision:
Auch bei mir waren die Daten nun von gestern ;)

Die aktuelle Beta läuft bei mir nicht mehr..
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
[16:51] Getting info for stations group 0
usw...

Ich weiß auch gar nicht mehr, was nun gerade die aktuelle Beta ist. Version steht immer noch bei v1.0.8.2. Schöne wäre eine Timeline wie bei Trac , damit man mitverfolgen kann, was geändert wurde.

Hallo Vision,

also bei mir läuft die Beta version:

07:02:00 <|bot|> [13.12.2011] (07:02:00) Starting to cache TV data...
07:02:00 <|bot|> [13.12.2011] (07:02:00) Getting TV Stations
07:02:01 <|bot|> [13.12.2011] (07:02:01) Found 221 Stations
07:02:01 <|bot|> [13.12.2011] (07:02:01) Getting info for stations group 0 (1 / 65)
07:02:01 <|bot|> [13.12.2011] (07:02:01) Got a new entry for ard: "05:30" "ZDF-Morgenmagazin" "Magazin"

08:46:33 <@burn> !tv
08:46:33 < |bot|> 08:40 (pro7) How I Met Your Mother [Einzelfolge]
08:46:34 <+NewS-FlasH> 08:40 (pro7) How I Met Your Mother [Einzelfolge]
08:46:35 < |bot|> 05:30 (sat1) Frühstücksfernsehen [Magazin]
08:46:36 <+NewS-FlasH> 05:30 (sat1) Frühstücksfernsehen [Magazin]
08:46:37 < |bot|> 08:30 (rtl) Gute Zeiten schlechte Zeiten [Einzelfolge]
08:46:39 <+NewS-FlasH> 08:30 (rtl) Gute Zeiten schlechte Zeiten [Einzelfolge]
08:46:40 < |bot|> 08:00 (rtlii) Infomercials [Werbung]
08:46:41 <+NewS-FlasH> 08:00 (rtlii) Infomercials [Werbung]
08:46:41 < |bot|> 07:05 (vox) Verklag mich doch! [Doku-Soap]
08:46:42 <+NewS-FlasH> 07:05 (vox) Verklag mich doch! [Doku-Soap]


Sogar auf zwei verschiedenen Bots, wie man sieht.
An sich hat sich an der Beta nichts verändert, die letzte Änderung war eben die Designanpassung. Ansonsten wurde von Cybex nur noch nen bind time auf 7 Uhr angelegt, damit falls die Daten beim 1. Cachen zu alt sind, diese noch mal neu geladen werden.
Vision  12-13-2011, 15:20  
Member since 09/2006
35 Posts
Location: Berlin
evtl. hab ich nur falsche Version gehabt ?!
Deswegen wäre mein Vorschlag auch, das man die Versionsnummern öfter ändert.

Cu Vision
burn  12-13-2011, 18:31   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Dies wird bei jeder Änderung gemacht, die letzte Designänderung lag nun auch schon ein paar Tage zurück.
poseidon  12-19-2011, 18:19  
Member since 09/2011
11 Posts
eine anregung... wärs möglich reminder über mehrere/alle sender zu implementieren? also zum beispiel wenn man * (oder möglicherweise einen regex) als sender angibt.
Vision  12-25-2011, 16:32  
Member since 09/2006
35 Posts
Location: Berlin
Mit der aktuellen Beta flutscht alles wieder.

Euch alles noch ein schönes Weihnachtsfest !

Cu Vision
grml  12-29-2011, 20:26  
Member since 11/2011
18 Posts
Bei mir sind fast jeden Tag von ein paar Sendern die Daten zu alt, oft vom Vortag.
Mit !tv reload passt es dann wieder, leider muss ich das halt fast jeden Tag machen
poseidon  12-29-2011, 20:29  
Member since 09/2011
11 Posts
same here..
Vision  12-29-2011, 20:58  
Member since 09/2006
35 Posts
Location: Berlin
jupp, bei mir auch

Cu Vision
CyBex  02-01-2012, 09:30   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
im moment scheint eh nix zu gehen oder nur sehr unzuverläßig. unsere quelle muss auf jedenfall überdacht und vermutlich geändert werden.. ideen sind da, es mangelt an zeit/lust und was weiss ich.. grins..

wildcards bei den reminds sind in sofern schlecht, weil die halt sehr cpu lastig sind, es müßten dann alle 5 minuten alle sender/sendungen durchgehen, und das müßte man zumindest erstmal dahingehend optimieren, das man bei dem foreach gleich alle sendungen prüft und nicht für jede sendung alle sender wieder komplett durchgeht..

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
kaputt02-14-2012, 16:39  
(Guest)
Script kaputt, zumindest der alte output, da tvm*vie bei sehr vielen sendern nun ein HD hinzugefügt hat :E
burn  02-14-2012, 18:47   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Naja, kaputt ist es nicht direkt, lediglich die Sender wurden umbenannt.
14:21:12 <@burn> !tv rtlhd 20:15
14:21:13 < |bot|> 20:15 (rtlhd) CSI: Miami
14:21:15 < |bot|> 21:15 (rtlhd) CSI: Miami
14:21:17 < |bot|> 22:15 (rtlhd) Royal Pains

Als Beispiel.

Leider wurden die Sendernamen umbenannt.
hansi02-14-2012, 21:24  
(Guest)
beim script jeweils bei rtl/k1 und so einfach ein hd hinten dranhängen bringt nix oder?
Vision  02-15-2012, 15:03  
Member since 09/2006
35 Posts
Location: Berlin
Lasst euch doch die senderliste anzeigen mit tv list. Dann einfach die Sender entsprechend umbenennen. zb. wird aus ard=ardhd, zdf=zdfhd usw usw...
Dauert nur wenige Minuten.

Cu Vision
kaputt02-15-2012, 20:25  
(Guest)
Hatte das schon vorher versucht mit einfach unbennen, war aber nicht wirklich erfolgreich, hälfte der Sender erkennt der trotzdem nicht...
nitro  02-18-2012, 21:28  
Member since 12/2011
10 Posts
Ich habe seit Tagen das Problem das mein Bot mir sagt "Sender nicht gefunden." weiß einer woran das liegen könnte?

Connection reset by myself
burn  02-19-2012, 08:20   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Quote by nitro:
Ich habe seit Tagen das Problem das mein Bot mir sagt "Sender nicht gefunden." weiß einer woran das liegen könnte?

Wenn du nur !tv benutzt, musst du deinem Skript natürlich die neuen Sender mitteilen, da in der tv-hauptliste sicher noch die alten Sendernamen verpackt sind.

Dies kannst du z.B. mit diesem Befehl setzen
                                                                                                                              
1
!tv set haupt pro7hd sat1hd rtlhd rtliihd voxhd


Alle Sendernamen kannst du mit
                                                                                                                              
1
!tv list

einsehen.
nitro  02-20-2012, 14:32  
Member since 12/2011
10 Posts
Hallo burn

Danke hat wunderbar geklappt
ich habe die sendernamen im script selbst auch auf hd leider startet er wenn ich den bot rehashen tu immer das cachen... ob ich die sender wieder zum alten benenne? und dann halt ard "ardhd" dann müsste das doch klappen oder?

andere frage nun gehen wa mal weiter im code ;)
wie kann ich die url cachen & mit anzeigen lassen? bzw wo muss ich genau ansetzen muss ich das <div class="right"> filtern?
also <a href="/wer-wird-millionaer-tv-1615016.html?bid=1370638" class="title"> weil hab schon geguckt aber so genau weiß ich nicht wo ich ansetzen soll

so das der bot anzeigt

20:15 (rtlhd) Wer wird Millionär? http://link.de

nitro

Connection reset by myself
Vision  06-11-2012, 18:05  
Member since 09/2006
35 Posts
Location: Berlin
Haben die wiedermal was geändert ??

Jetzt bekomme ich nur noch:
Getting info for stations group 0

;)

Cu Vision
grml  06-11-2012, 20:06  
Member since 11/2011
18 Posts
bei mir kommt auch nur noch

"Sender nicht gefunden."
shivaz  06-11-2012, 21:34  
Member since 10/2011
3 Posts
Location: Istanbul
hatte ich auch,

hatte proformaweise mal die tv.cache und die tvm*vie gelöscht
bot neu gestartet danach ging es wieder,
entweder wars bei mir einfach nur dummen-glück
aber es funzt einwandfrei.
CyBex  06-12-2012, 08:50   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
bUrN hat noch eine andere Lösung.. !tcl unset ::tv

dann ging es auch weiter... und er hat auch ein paar kleine Änderungen gemacht, damit die Kategorie zB [Daily Soap] wieder angezeigt werden..

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
grml  06-13-2012, 18:53  
Member since 11/2011
18 Posts
.tcl unset ::tv

danke, das hat bei mir das problem gelöst!
grml  06-13-2012, 19:06  
Member since 11/2011
18 Posts
gerade gesehen das der bot jetzt ständig cached


[18:47] Starting to cache TV data...
[18:47] Getting TV Stations
[18:47] Found 186 Stations
[18:51] Okay, cached all data
[18:52] Starting to cache TV data...
[18:52] Getting TV Stations
[18:52] Found 186 Stations
[18:56] Okay, cached all data
[18:56] Starting to cache TV data...
[18:56] Getting TV Stations
[18:56] Found 186 Stations
[19:00] Okay, cached all data
[19:00] Starting to cache TV data...
[19:00] Getting TV Stations
[19:00] Found 186 Stations
[19:05] Okay, cached all data
[19:05] Starting to cache TV data...
[19:05] Getting TV Stations
[19:05] Found 186 Stations

ps.: kann man seinen beitrag nicht editieren?
burn  06-13-2012, 19:31   Jabber  ICQ  MSN
(Administrator)
Member since 03/2004
38 Posts
Location: Germany, Nürnberg
Doch, dein Beiträg lässt sich editieren, wenn du in den oberen rechten Bereich deines Beitrags schaust, sollte sich dieses Symbol befinden.
[Not loaded: http://tclhelp.net/unb/bb_designs/standard/img/edit.png]

Restarte vielleicht mal komplett deinen Bot, vielleicht lief noch ein zweiter Timer, so dass sich jetzt etwas überschnitten hat.
grml  06-14-2012, 20:42  
Member since 11/2011
18 Posts
Oh alles klar, editierfunktion gefunden ^^

Gerade nochmal geschaut, der "fehler" hörte nach ein paar stunden auf, läuft jetzt also normal.
Sebbel  06-16-2012, 17:05  
Member since 06/2012
3 Posts
Hallo,

aktuell scheint das Script wohl immer mehr Probleme zu machen.

Nach anfänglichen "kein Sender gefunden", ist es nun soweit, dass hier täglich die Daten nicht mehr aktuell sind. Und nur noch mit !tv reload, aktualisiert werden.

Neustart des Bots und Vorschlag hier im Thread hab ich schon durch.
grml  06-19-2012, 21:20  
Member since 11/2011
18 Posts
Bei mir kamen heute auch die Daten von gestern.

Nach .tcl unset ::tv geht es aber wieder


achja mal was anderes.. wenn ich öfters mal die sender abfrage, also mit !tv,
bringt mir der bot die irgendwann nur noch als notice, wie änder ich das,
dass er mir die immer im channel ausgibt? hat ja glaube ich was mit der
flood protection zutun!? bin mir aber gerade nicht sicher
shivaz  06-19-2012, 22:08  
Member since 10/2011
3 Posts
Location: Istanbul
Beispiel:
!tv set flood 5:600 (erlaubt 5x in 10 minuten und antwortet danach als Notice und nicht mehr öffentlich)
CyBex  06-19-2012, 22:21   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Im moment gibs eh ein größeres Problem, scheinbar ist die komplette IP-Range von 1+1 von TVM*vie gesperrt worden und wir können selbst garnix mehr holen. Sofern ihr überhaupt noch eine Antwort bekommt, könnt ihr euch glücklich schätzen. Bei uns hilft kein reload oder sonst was mehr. Und dummerweise hängen wir alle 3 (die an dem Script rumfummeln) an einem 1+1 Server.

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
grml  06-20-2012, 20:55  
Member since 11/2011
18 Posts
Danke dir shivaz!

@CyBex
Oh das ist aber ne harte Aktion von denen!
Mein Server läuft im Ausland somit gibts bei mir keine Probleme.

Könnt ihr eure Bots nicht solange über einen Proxy laufen lassen?
Außer es ist natürlich gerade nicht so wichtig.
CyBex  06-20-2012, 22:35   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
hat sich nun nach einer woche von selbst aufgelöst das problem..

wir haben schon eine lösung und damit sind auch gleich ein paar änderungen in das script eingeflossen, in verbindung mit dem addon script funktioniert jetzt zuimndest die master<>slave funktion mit dem holen der daten ganz gut, das nu noch ein bot die holen brauch, wenn mehrere mit dem tv script laufen..

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
CyBex  06-21-2012, 09:02   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
Bitte beteiligt euch mal bei unserer Umfrage für ein besseres TV Script:

http://tclhelp.net/unb/309

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
Sebbel  06-21-2012, 16:12  
Member since 06/2012
3 Posts
Moin,

was muss ich denn installierten damit .tcl unset ::tv funktioniert?
Bei mir kommt immer nur "What?  You need '.help'" ;).

Das neue Script hat das Problem mit den alten Daten, übrigens auch nicht verbessert.
CyBex  06-21-2012, 16:16   Jabber  ICQ  AOL IM  Yahoo IM  MSN  Homepage
nie da
(Administrator)

Avatar

Member since 01/2004
260 Posts
Location: Berlin
.tcl: To enable the .tcl or .set partyline-command you have to change the corresponding line "unbind dcc n tcl/set *dcc:tcl/set" in your eggdrop.conf to "bind dcc n tcl/set *dcc:tcl/set", make sure your handle is in "set owner "YourHandle"" or change must-be-owner and then .restart

Was für alte Daten, was für ein Problem? Also die neue Version lädt nun die Daten die es in der Nacht geholt hat einwandfrei aus der Datei.. Aber der Content Anbieter hat heute zB bis 11 Uhr den Tag von gestern ausgeliefert...

mfG CyBex @ QuakeNet, UnderNet, EFNet, Freenode, euIRC, GameSurge & ShadowWorld - Files
This post was edited 1 times, last on 06-21-2012, 16:18 by CyBex
Sebbel  06-23-2012, 18:59  
Member since 06/2012
3 Posts
Moin,

ich habe immer die Werte von gestern drin.

Heute z.B. immer noch "Deutschland - Griechenland" beim ZDF.

Erst ein !tv reload bringt aktuelle Daten.
Advanced options for this topic:

Ignore this topic (Do not list this topic in the "unread topics" search. You are currently not ignoring this topic.)
Hide this topic (Hidden topics are not displayed in the topics list. This topic is currently not hidden.)
Go to forum

Unclassified NewsBoard 1.5.3-d | © 2003-4 by Yves Goergen | Time: 196.2 msec, CPU time: 100.7 msec, 129 Database queries in 120.9 msec | 11.7 kB (105 kB) | Timezone: +0200